Add in a few useful bits for font handling
authorEric Andersen <andersen@codepoet.org>
Tue, 16 Jan 2007 08:10:27 +0000 (08:10 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 16 Jan 2007 08:10:27 +0000 (08:10 -0000)
package/fontconfig/fontconfig.mk

index 27f529ad61ff6080ca61546ffaf8d573982e2d67..49e4b70b2f3bc31d502e1a5f5a2521cb39b36c16 100644 (file)
@@ -59,6 +59,12 @@ $(TARGET_DIR)/lib/libfontconfig.so: $(STAGING_DIR)/lib/libfontconfig.so
        mkdir -p $(TARGET_DIR)/etc/fonts
        cp $(STAGING_DIR)/etc/fonts/fonts.conf $(TARGET_DIR)/etc/fonts/
        -$(STRIP) --strip-unneeded $(TARGET_DIR)/lib/libfontconfig.so
+       mkdir -p $(TARGET_DIR)/var/cache/fontconfig
+       mkdir -p $(TARGET_DIR)/usr/bin
+       cp -a $(STAGING_DIR)/usr/bin/fc-cache $(TARGET_DIR)/usr/bin/
+       -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/fc-cache
+       cp -a $(STAGING_DIR)/usr/bin/fc-list $(TARGET_DIR)/usr/bin/
+       -$(STRIP) --strip-unneeded $(TARGET_DIR)/usr/bin/fc-list
 
 fontconfig: uclibc freetype $(TARGET_DIR)/lib/libfontconfig.so