wireshark: add snappy optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Nov 2018 10:10:30 +0000 (11:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Nov 2018 23:21:36 +0000 (00:21 +0100)
- Optional dependency to snappy has been added with version 2.4.0 and
  https://github.com/wireshark/wireshark/commit/47649d1c7fb6ba48b805e19268a711404eb6908b
- Specify the path to found libssh as this is done for other options

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index f42dca1c864ff5447d897c0ae72143c3a8616ccf..2e41c3d65295445b916b45a1513c853c54ea5b9c 100644 (file)
@@ -16,7 +16,6 @@ WIRESHARK_CONF_ENV = \
 
 WIRESHARK_CONF_OPTS = \
        --enable-static=no \
-       --without-snappy \
        --with-libsmi=no \
        --with-pcap=$(STAGING_DIR)/usr
 
@@ -135,6 +134,13 @@ else
 WIRESHARK_CONF_OPTS += --with-sbc=no
 endif
 
+ifeq ($(BR2_PACKAGE_SNAPPY),y)
+WIRESHARK_CONF_OPTS += --with-snappy=$(STAGING_DIR)/usr
+WIRESHARK_DEPENDENCIES += snappy
+else
+WIRESHARK_CONF_OPTS += --without-snappy
+endif
+
 define WIRESHARK_REMOVE_DOCS
        find $(TARGET_DIR)/usr/share/wireshark -name '*.txt' -print0 \
                -o -name '*.html' -print0 | xargs -0 rm -f