cryptopp: use HOST_CRYPTOPP_DL_DIR instead of CRYPTOPP_DL_DIR
authorMaxime Hadjinlian <maxime.hadjinlian@gmail.com>
Mon, 2 Apr 2018 18:36:23 +0000 (20:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 2 Apr 2018 18:50:52 +0000 (20:50 +0200)
The infrastructure only provides HOST_CRYPTOPP_DL_DIR, because this
package is host only. Ideally the infra should provide CRYPTOPP_DL_DIR,
but it doesn't currently, and that requires more significant changes.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cryptopp/cryptopp.mk

index 6da39b09f25cb2f6f34c4467324aaf8d15fd048f..b4997aba9da9abe73191d08bf242c431f5c4a2eb 100644 (file)
@@ -12,7 +12,7 @@ CRYPTOPP_LICENSE_FILES = License.txt
 CRYPTOPP_INSTALL_STAGING = YES
 
 define HOST_CRYPTOPP_EXTRACT_CMDS
-       $(UNZIP) $(CRYPTOPP_DL_DIR)/$(CRYPTOPP_SOURCE) -d $(@D)
+       $(UNZIP) $(HOST_CRYPTOPP_DL_DIR)/$(CRYPTOPP_SOURCE) -d $(@D)
 endef
 
 HOST_CRYPTOPP_MAKE_OPTS = \