nss-mdns: drop nsswitch.conf installation logic
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Oct 2018 21:35:45 +0000 (23:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 20 Oct 2018 23:50:35 +0000 (01:50 +0200)
With the nsswitch.conf installation logic moved to the post-install-install
hook of the toolchain package, it is guaranteed to be available when
nss-mdns is run - So drop the logic.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nss-mdns/nss-mdns.mk

index ee666c76a00c7b9acd8cc666a5d379c0d9106164..63f40e718a8bdab0ad23eafe66f7124eb92bd40f 100644 (file)
@@ -10,9 +10,6 @@ NSS_MDNS_LICENSE = LGPL-2.1+
 NSS_MDNS_LICENSE_FILES = LICENSE
 
 define NSS_MDNS_INSTALL_CONFIG
-       if [ ! -f "$(TARGET_DIR)/etc/nsswitch.conf" ]; then \
-               $(INSTALL) -D -m 0644 package/glibc/nsswitch.conf $(TARGET_DIR)/etc/nsswitch.conf ; \
-       fi
        sed -r -i -e 's/^(hosts:[[:space:]]+).*/\1files mdns4_minimal [NOTFOUND=return] dns mdns4/' \
                $(TARGET_DIR)/etc/nsswitch.conf
 endef