openssl: fix m68k uclinux compile
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 31 Jul 2016 18:48:00 +0000 (20:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 1 Aug 2016 21:03:24 +0000 (23:03 +0200)
The GCC manual suggest when getting:
relocation truncated to fit: R_68K_GOT16O foobar
to use -mxgot.

Fixes:
http://autobuild.buildroot.net/results/455fd0f274bfa4bbd786bcd6740ecf960e47c1bd/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openssl/openssl.mk

index e34868e842a5e8b85b6c6d1f8d6b309e585cfc2c..b926fe30af8f32f9890bb279b4f50c2bef881157 100644 (file)
@@ -19,6 +19,11 @@ OPENSSL_PATCH = \
        https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2a-parallel-install-dirs.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d \
        https://gitweb.gentoo.org/repo/gentoo.git/plain/dev-libs/openssl/files/openssl-1.0.2a-parallel-symlinking.patch?id=c8abcbe8de5d3b6cdd68c162f398c011ff6e2d9d
 
+# relocation truncated to fit: R_68K_GOT16O
+ifeq ($(BR2_m68k_cf),y)
+OPENSSL_CFLAGS += -mxgot
+endif
+
 ifeq ($(BR2_USE_MMU),)
 OPENSSL_CFLAGS += -DHAVE_FORK=0
 endif