package/nodejs: add icu support
authorMartin Bark <martin@barkynet.com>
Fri, 3 Jun 2016 10:41:16 +0000 (11:41 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 12:47:44 +0000 (14:47 +0200)
Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/nodejs/nodejs.mk

index b0661ed98677754a6acb2a40253cb26eac3d495f..0329299fe052735ded853d68de275ecb6acc3683 100644 (file)
@@ -17,6 +17,10 @@ ifeq ($(BR2_PACKAGE_OPENSSL),y)
 NODEJS_DEPENDENCIES += openssl
 endif
 
+ifeq ($(BR2_PACKAGE_ICU),y)
+NODEJS_DEPENDENCIES += icu
+endif
+
 # nodejs build system is based on python, but only support python-2.6 or
 # python-2.7. So, we have to enforce PYTHON interpreter to be python2.
 define HOST_NODEJS_CONFIGURE_CMDS
@@ -96,6 +100,7 @@ define NODEJS_CONFIGURE_CMDS
                --without-snapshot \
                --shared-zlib \
                $(if $(BR2_PACKAGE_OPENSSL),--shared-openssl,--without-ssl) \
+               $(if $(BR2_PACKAGE_ICU),--with-intl=system-icu,--with-intl=none) \
                $(if $(BR2_PACKAGE_NODEJS_NPM),,--without-npm) \
                --without-dtrace \
                --without-etw \