evtest: add as a seperate package
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Sep 2012 10:04:49 +0000 (12:04 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 Sep 2012 20:08:39 +0000 (22:08 +0200)
Evtest is nowadays maintained as a seperate package by Peter Hutterer.

The project doesn't release any tarballs, so use the one of Fedora instead
so we don't need to autoreconf:

http://comments.gmane.org/gmane.comp.freedesktop.xorg.announce/1671

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/evtest/Config.in [new file with mode: 0644]
package/evtest/evtest.mk [new file with mode: 0644]

index 58dd5e80dca77a259ff6b0ca60e6bd0aeb538f08..d777454cdf42cc657401a32b342b568c52a4397a 100644 (file)
@@ -197,6 +197,7 @@ endif
 source "package/dmidecode/Config.in"
 source "package/dmraid/Config.in"
 source "package/eeprog/Config.in"
+source "package/evtest/Config.in"
 source "package/flashrom/Config.in"
 source "package/fconfig/Config.in"
 source "package/fis/Config.in"
diff --git a/package/evtest/Config.in b/package/evtest/Config.in
new file mode 100644 (file)
index 0000000..e8f9e37
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_EVTEST
+       bool "evtest"
+       help
+         evtest displays information on the input device specified on
+         the command line, including all the events supported by the
+         device. It then monitors the device and displays all the
+         events layer events generated.
+
+         http://www.freedesktop.org/wiki/Evtest
+
+config BR2_PACKAGE_EVTEST_CAPTURE
+       bool "evtest-capture"
+       depends on BR2_PACKAGE_EVTEST
+       select BR2_PACKAGE_LIBXML2
+       help
+         evtest-capture captures the information and events from the
+         input device specified on the command line and writes it to
+         the xml file given.
diff --git a/package/evtest/evtest.mk b/package/evtest/evtest.mk
new file mode 100644 (file)
index 0000000..582d1a7
--- /dev/null
@@ -0,0 +1,28 @@
+#############################################################
+#
+# evtest
+#
+#############################################################
+
+EVTEST_VERSION = 1.30
+EVTEST_SOURCE = evtest-$(EVTEST_VERSION).tar.bz2
+# no official upstream tarball
+EVTEST_SITE = http://pkgs.fedoraproject.org/repo/pkgs/evtest/evtest-1.30.tar.bz2/27c0902839babfd07136f232c63c895c/
+EVTEST_LICENSE = GPLv2
+EVTEST_LICENSE_FILES = COPYING
+EVTEST_DEPENDENCIES = host-pkg-config
+
+ifeq ($(BR2_PACKAGE_EVTEST_CAPTURE),y)
+EVTEST_DEPENDENCIES += libxml2
+else
+# evtest-capture will unconditionally be built/installed if libxml2 is present
+define EVTEST_REMOVE_EVTEST_CAPTURE
+       rm -rf $(TARGET_DIR)/usr/bin/evtest-capture \
+              $(TARGET_DIR)/usr/share/evtest \
+              $(TARGET_DIR)/usr/share/man/man1/evtest-capture.1
+endef
+
+EVTEST_POST_INSTALL_TARGET_HOOKS += EVTEST_REMOVE_EVTEST_CAPTURE
+endif
+
+$(eval $(autotools-package))