php-imagick: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 28 Jan 2014 21:26:31 +0000 (18:26 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 12 Feb 2014 14:57:48 +0000 (15:57 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/php-imagick/Config.in [new file with mode: 0644]
package/php-imagick/php-imagick.mk [new file with mode: 0644]

index 1fd47191d35a464bf717df2ee74716f4923cb187..19c9c4bc4512d4216ee0572ea48108b28a09cb7f 100644 (file)
@@ -397,6 +397,7 @@ source "package/php/Config.in"
 if BR2_PACKAGE_PHP
 if !BR2_PREFER_STATIC_LIB
 menu "External php extensions"
+source "package/php-imagick/Config.in"
 source "package/php-ssh2/Config.in"
 source "package/php-yaml/Config.in"
 source "package/php-zmq/Config.in"
diff --git a/package/php-imagick/Config.in b/package/php-imagick/Config.in
new file mode 100644 (file)
index 0000000..1d55fcc
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PHP_IMAGICK
+       bool "php-imagick"
+       depends on BR2_PACKAGE_PHP
+       select BR2_PACKAGE_IMAGEMAGICK
+       help
+         PHP wrapper to the ImageMagick library.
+
+         http://pecl.php.net/package/imagick
diff --git a/package/php-imagick/php-imagick.mk b/package/php-imagick/php-imagick.mk
new file mode 100644 (file)
index 0000000..148d519
--- /dev/null
@@ -0,0 +1,26 @@
+################################################################################
+#
+# php-imagick
+#
+################################################################################
+
+PHP_IMAGICK_VERSION = 3.1.2
+PHP_IMAGICK_SOURCE = imagick-$(PHP_IMAGICK_VERSION).tgz
+PHP_IMAGICK_SITE = http://pecl.php.net/get
+PHP_IMAGICK_CONF_OPT = --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+       --with-imagick=$(STAGING_DIR)/usr
+# phpize does the autoconf magic
+PHP_IMAGICK_DEPENDENCIES = imagemagick php host-autoconf
+PHP_IMAGICK_LICENSE = PHP
+PHP_IMAGICK_LICENSE_FILES = LICENSE
+
+define PHP_IMAGICK_PHPIZE
+       (cd $(@D); \
+               PHP_AUTOCONF=$(HOST_DIR)/usr/bin/autoconf \
+               PHP_AUTOHEADER=$(HOST_DIR)/usr/bin/autoheader \
+               $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_IMAGICK_PRE_CONFIGURE_HOOKS += PHP_IMAGICK_PHPIZE
+
+$(eval $(autotools-package))