linux: add ev3dev extension
authorDavid Lechner <david@lechnology.com>
Wed, 2 Nov 2016 03:15:55 +0000 (22:15 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 2 Nov 2016 16:52:24 +0000 (17:52 +0100)
This adds an ev3dev Linux drivers extension that provides Linux kernel
drivers for LEGO MINDSTORMS EV3 from the ev3dev project.

Signed-off-by: David Lechner <david@lechnology.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/Config.ext.in
linux/linux-ext-ev3dev-linux-drivers.mk [new file with mode: 0644]
package/Config.in
package/ev3dev-linux-drivers/Config.in [new file with mode: 0644]
package/ev3dev-linux-drivers/ev3dev-linux-drivers.mk [new file with mode: 0644]
package/ev3dev-linux-drivers/lego-linux-drivers.hash [new file with mode: 0644]
support/scripts/pkg-stats

index 5d5e7efbca3fdd3ef3ea8edbb975c4e010c835e6..011dffb0b156e690460fcc900170f3dbe7aed4c7 100644 (file)
@@ -45,6 +45,16 @@ config BR2_LINUX_KERNEL_EXT_RTAI
        help
          RTAI Kernel part.
 
+#-------------------------------------------------------------------------------
+# ev3dev Linux drivers
+config BR2_LINUX_KERNEL_EXT_EV3DEV_LINUX_DRIVERS
+       bool "ev3dev Linux drivers"
+       select BR2_PACKAGE_EV3DEV_LINUX_DRIVERS
+       help
+         Linux drivers for LEGO MINDSTORMS EV3 from the ev3dev project.
+
+         https://github.com/ev3dev/lego-linux-drivers
+
 #-------------------------------------------------------------------------------
 # fbtft
 config BR2_LINUX_KERNEL_EXT_FBTFT
diff --git a/linux/linux-ext-ev3dev-linux-drivers.mk b/linux/linux-ext-ev3dev-linux-drivers.mk
new file mode 100644 (file)
index 0000000..c8afeeb
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+# Linux ev3dev extensions
+#
+# Patch the linux kernel with ev3dev extension
+################################################################################
+
+LINUX_EXTENSIONS += ev3dev-linux-drivers
+
+define EV3DEV_LINUX_DRIVERS_PREPARE_KERNEL
+       mkdir -p $(LINUX_DIR)/drivers/lego
+       cp -dpfr $(EV3DEV_LINUX_DRIVERS_DIR)/* $(LINUX_DIR)/drivers/lego/
+endef
index 0f6260b2d2b38859a4f144c2b269e0db246c5bbe..9ed296f2d9236717e72b3d29e191a3f46b169383 100644 (file)
@@ -369,6 +369,7 @@ endmenu
        source "package/edid-decode/Config.in"
        source "package/eeprog/Config.in"
        source "package/eudev/Config.in"
+       source "package/ev3dev-linux-drivers/Config.in"
        source "package/evemu/Config.in"
        source "package/evtest/Config.in"
        source "package/fan-ctrl/Config.in"
diff --git a/package/ev3dev-linux-drivers/Config.in b/package/ev3dev-linux-drivers/Config.in
new file mode 100644 (file)
index 0000000..9be2f28
--- /dev/null
@@ -0,0 +1,12 @@
+# Prompt-less option, because this package is not doing anything except
+# downloading the ev3dev driver sources. The real work is done by a Linux
+# extension.
+config BR2_PACKAGE_EV3DEV_LINUX_DRIVERS
+       bool
+       depends on BR2_LINUX_KERNEL
+       help
+         Linux drivers for LEGO MINDSTORMS EV3
+
+         This is only the download helper for the kernel patch.
+
+         https://github.com/ev3dev/lego-linux-drivers
diff --git a/package/ev3dev-linux-drivers/ev3dev-linux-drivers.mk b/package/ev3dev-linux-drivers/ev3dev-linux-drivers.mk
new file mode 100644 (file)
index 0000000..55e26f0
--- /dev/null
@@ -0,0 +1,11 @@
+################################################################################
+#
+# ev3dev Linux drivers
+#
+################################################################################
+
+EV3DEV_LINUX_DRIVERS_VERSION = 0e551eb25ae8600c1f178814781bfb42dc835496
+EV3DEV_LINUX_DRIVERS_SITE = $(call github,ev3dev,lego-linux-drivers,$(EV3DEV_LINUX_DRIVERS_VERSION))
+EV3DEV_LINUX_DRIVERS_LICENSE = GPLv2
+
+$(eval $(generic-package))
diff --git a/package/ev3dev-linux-drivers/lego-linux-drivers.hash b/package/ev3dev-linux-drivers/lego-linux-drivers.hash
new file mode 100644 (file)
index 0000000..cc48f65
--- /dev/null
@@ -0,0 +1,2 @@
+# locally computed
+sha256  9d2740b348c8d43e7e15fedc4cec99bf351a3a2ba8691f2a07c439a9c034bc04  lego-linux-drivers-0e551eb25ae8600c1f178814781bfb42dc835496.tar.gz
index cc3bef452c4ae326db96f9f73d25ca82f213ea84..421fa5cf5d0ff6d02730edeb888f697abc661847 100755 (executable)
@@ -94,6 +94,7 @@ for i in $(find boot/ linux/ package/ -name '*.mk' | sort) ; do
 
     if test \
        $i = "boot/common.mk" -o \
+       $i = "linux/linux-ext-ev3dev-linux-drivers.mk" -o \
        $i = "linux/linux-ext-fbtft.mk" -o \
        $i = "linux/linux-ext-xenomai.mk" -o \
        $i = "linux/linux-ext-rtai.mk" -o \