wget: add upstream patch to fix build failure
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Fri, 10 Feb 2017 06:54:40 +0000 (12:24 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Feb 2017 14:17:41 +0000 (15:17 +0100)
Fixes:
  http://autobuild.buildroot.net/results/c86/c8657563e63e1012a3ae3c0c47663a951e280022

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wget/0002-Remove-skipping-libunistring-with-disable-iri.patch [new file with mode: 0644]
package/wget/wget.mk

diff --git a/package/wget/0002-Remove-skipping-libunistring-with-disable-iri.patch b/package/wget/0002-Remove-skipping-libunistring-with-disable-iri.patch
new file mode 100644 (file)
index 0000000..a1461df
--- /dev/null
@@ -0,0 +1,35 @@
+From 990f3d67d340d226bbd4187f5d310a4d2bf2bfe4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Mon, 6 Feb 2017 11:25:48 +0100
+Subject: [PATCH] Remove skipping libunistring with --disable-iri
+
+* configure.ac: Remove checking for IRI=no
+
+On certain systems, gnulib falls back to libunistring
+for mbtowc() and wcwidth() (used in src/progress.c).
+
+Reported-by: Zhiming Wang
+Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
+---
+ configure.ac | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8786e00..686f040 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -663,11 +663,6 @@ if test "X$iri" != "Xno"; then
+ #    ])
+   ])
+ fi
+-if test "X$iri" = "Xno"; then
+-  # we don't need libunistring - clear settings from gnulib module
+-  LIBUNISTRING=""
+-  LTLIBUNISTRING=""
+-fi
+ dnl
+ dnl Check for UUID
+-- 
+2.6.2
+
index e0f680bb7e60cf74e88810eee1826e6f17c83899..8698cdf3a77950a6f5e29c60ca26a1c2dc5eb9fa 100644 (file)
@@ -11,6 +11,9 @@ WGET_DEPENDENCIES = host-pkgconf
 WGET_LICENSE = GPLv3+
 WGET_LICENSE_FILES = COPYING
 
+# For 0002-Remove-skipping-libunistring-with-disable-iri.patch
+WGET_AUTORECONF = YES
+
 # Prefer full-blown wget over busybox
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 WGET_DEPENDENCIES += busybox