package/cpio: add argp-standalone dependency with musl
authorRomain Naour <romain.naour@openwide.fr>
Fri, 7 Aug 2015 22:47:16 +0000 (00:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Aug 2015 09:16:04 +0000 (11:16 +0200)
Since argp-standalone is only available for uClibc-ng
and musl toolchains, add the dependendy only if it's
selected.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cpio/Config.in
package/cpio/cpio.mk

index df40faccf8f73e7b0323ea6dc18bc0b84c14341b..1210a0bde148fe96a759f96458e60a1ef48f740d 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_CPIO
        bool "cpio"
        # Need argp.h support
-       select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC
+       select BR2_PACKAGE_ARGP_STANDALONE if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_USE_WCHAR
        help
          cpio archive utility for creation and extraction.
index aa9daced176b43902c35606f49ab9dcae35591c7..e18af8140bcf8f8b84295f3d56738be202370226 100644 (file)
@@ -15,10 +15,10 @@ CPIO_PATCH = \
        https://projects.archlinux.org/svntogit/packages.git/plain/cpio/trunk/cpio-2.11-check_for_symlinks-CVE-2015-1197.patch \
        https://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/app-arch/cpio/files/cpio-2.11-stat.patch
 
-# cpio uses argp.h which is not provided by uclibc by default.
+# cpio uses argp.h which is not provided by uclibc or musl by default.
 # Use the argp-standalone package to provide this but make sure
 # the host package does not try to use the host version.
-ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
 CPIO_DEPENDENCIES += argp-standalone
 endif