package/dovecot: Fix build error in SQLite module
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sat, 8 Nov 2014 09:36:05 +0000 (10:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Nov 2014 22:54:16 +0000 (23:54 +0100)
Patch occured with "make dovecot" using this defconfig:
http://autobuild.buildroot.net/results/bd3/bd37ee92eeb00adb1558dbb61315465a0cdfe635/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dovecot/0001-zlib.patch [new file with mode: 0644]

diff --git a/package/dovecot/0001-zlib.patch b/package/dovecot/0001-zlib.patch
new file mode 100644 (file)
index 0000000..a6187bf
--- /dev/null
@@ -0,0 +1,24 @@
+SQLite does not depend on zlib
+
+Fixes build error when zlib target package is not present:
+/home/br/br2/output/host/opt/ext-toolchain/bin/../lib/gcc/arm-linux-gnueabihf/4.9.2/../../../../arm-linux-gnueabihf/bin/ld: cannot find -lz
+
+Patch for configure.ac sent upstream:
+http://www.dovecot.org/list/dovecot/2014-November/098634.html
+
+Here we patch ./configure instead because autoreconf is broken.
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+
+diff -uNr dovecot-2.2.15.org/configure dovecot-2.2.15/configure
+--- dovecot-2.2.15.org/configure       2014-10-25 06:08:57.000000000 +0200
++++ dovecot-2.2.15/configure   2014-11-08 10:08:53.430745198 +0100
+@@ -23865,7 +23865,7 @@
+               ac_fn_c_check_header_mongrel "$LINENO" "sqlite3.h" "ac_cv_header_sqlite3_h" "$ac_includes_default"
+ if test "x$ac_cv_header_sqlite3_h" = xyes; then :
+-                      SQLITE_LIBS="$SQLITE_LIBS -lsqlite3 -lz"
++                      SQLITE_LIBS="$SQLITE_LIBS -lsqlite3"
+ $as_echo "#define HAVE_SQLITE /**/" >>confdefs.h