package/nbd: bump to version 3.20
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 6 Oct 2019 18:04:31 +0000 (20:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 8 Oct 2019 21:04:19 +0000 (23:04 +0200)
- Remove patch (already in version)
- Add upstream patch to close the file descriptor before returning

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Yann E. MORIN <yann.morin.1998@free.fr>
Tested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nbd/0001-Also-close-the-file-descriptor-before-returning.patch [new file with mode: 0644]
package/nbd/0001-avoid-name-clashing.patch [deleted file]
package/nbd/nbd.hash
package/nbd/nbd.mk

diff --git a/package/nbd/0001-Also-close-the-file-descriptor-before-returning.patch b/package/nbd/0001-Also-close-the-file-descriptor-before-returning.patch
new file mode 100644 (file)
index 0000000..70330c8
--- /dev/null
@@ -0,0 +1,25 @@
+From d2480de925e83c8bf60faa96141f4198bdf7f619 Mon Sep 17 00:00:00 2001
+From: Wouter Verhelst <w@uter.be>
+Date: Fri, 2 Aug 2019 10:33:00 +0200
+Subject: [PATCH] Also close the file descriptor before returning
+
+Coverity CID#1162721
+[Retrieved from:
+https://github.com/NetworkBlockDevice/nbd/commit/d2480de925e83c8bf60faa96141f4198bdf7f619]
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ nbd-client.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/nbd-client.c b/nbd-client.c
+index e9ec0a86..94035886 100644
+--- a/nbd-client.c
++++ b/nbd-client.c
+@@ -930,6 +930,7 @@ void disconnect(char* device) {
+       if (ioctl(nbd, NBD_CLEAR_SOCK)<0)
+               err("Ioctl failed: %m\n");
+       printf("done\n");
++      close(nbd);
+ }
+ #if HAVE_NETLINK
diff --git a/package/nbd/0001-avoid-name-clashing.patch b/package/nbd/0001-avoid-name-clashing.patch
deleted file mode 100644 (file)
index b3ea9c9..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-rename err() function to avoid clashing with err() form C library
-
-err() is a function available in the C library, so when static linking,
-there is a clash at link timebecause the function is provided both by
-nbd and the C library:
-    http://autobuild.buildroot.org/results/aa8/aa8a1ac35a93e1c8b9fddbc2b5d66ecaa921f31e/build-end.log
-
-Fix that by renaming err() to nbd_err() and providing a small maco
-wrapper to avoid touching the many call sites.
-
-Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
-
----
-Upstream status: hack, not submitted.
-
-diff -durN nbd-3.11.orig/cliserv.h nbd-3.11/cliserv.h
---- nbd-3.11.orig/cliserv.h    2015-05-25 12:27:56.000000000 +0200
-+++ nbd-3.11/cliserv.h 2015-08-13 19:28:21.609467505 +0200
-@@ -75,7 +75,8 @@
- void setmysockopt(int sock);
- void err_nonfatal(const char *s);
--void err(const char *s) G_GNUC_NORETURN;
-+void nbd_err(const char *s) G_GNUC_NORETURN;
-+#define err(S) nbd_err(S)
- void logging(const char* name);
index fab14072c9d2f9395819ea089f3faf291218288d..d856953c22be96c8a307fb34ad89ffc65e797dbc 100644 (file)
@@ -1,7 +1,7 @@
-# From http://sourceforge.net/projects/nbd/files/nbd/3.19/
-md5    162da84302abb5b9be06143c7943a642        nbd-3.19.tar.xz
-sha1   97edd98f7323a2fcd0dcf441f307d348cdbbb807        nbd-3.19.tar.xz
+# From http://sourceforge.net/projects/nbd/files/nbd/3.20/
+md5    910fe6c152f8c30ad8608388e6a4ce89        nbd-3.20.tar.xz
+sha1   9240430266ff4bfb2316ef6d880056a9974a59fd        nbd-3.20.tar.xz
 
 # Locally calculated
-sha256 b4466412f13e057659f25d35e1e8e181afd62c7179bff22a6add81445ecb8690        nbd-3.19.tar.xz
+sha256 e0e1b3538ab7ae5accf56180afd1a9887d415b98d21223b8ad42592b4af7d6cd        nbd-3.20.tar.xz
 sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643        COPYING
index fa569f322446d934d89bbd243d06342ac383fb39..5fd5555510f849578a4f1b42ef9b00b361470d67 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-NBD_VERSION = 3.19
+NBD_VERSION = 3.20
 NBD_SOURCE = nbd-$(NBD_VERSION).tar.xz
 NBD_SITE = http://downloads.sourceforge.net/project/nbd/nbd/$(NBD_VERSION)
 NBD_CONF_OPTS = --enable-lfs