luajit: needs for 32bit archictectures a 32bit host gcc
authorFabio Porcedda <fabio.porcedda@gmail.com>
Mon, 7 Apr 2014 09:56:50 +0000 (11:56 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 16 Apr 2014 17:53:57 +0000 (19:53 +0200)
For 32 bit archictectures the luajit package needs a host compiler
able to generate 32 bit code using the "-m32" option so check if that
option is supported.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: François Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/luajit/Config.in

index 5176cb864d78edffea95c062abb50c975d96ea51..57c9e2d242e57aad65a8f17198594e294c2e85a8 100644 (file)
@@ -5,6 +5,10 @@ config BR2_PACKAGE_LUAJIT
        # has some complexity wrt 32/64. See luajit.mk for details.
        depends on BR2_i386 || (BR2_x86_64 && BR2_HOSTARCH='x86_64') || BR2_powerpc || BR2_arm || BR2_armeb \
                   || ((BR2_mips || BR2_mipsel) && !BR2_MIPS_SOFT_FLOAT)
+       # luajit.mk uses the "-m32" compiler option to build 32bit
+       # binaries, so check if that option is supported. See
+       # luajit.mk for details.
+       select BR2_HOSTARCH_NEEDS_IA32_COMPILER if !BR2_ARCH_IS_64
        help
          LuaJIT implements the full set of language features defined
          by Lua 5.1. The virtual machine (VM) is API- and