bluez5_utils: fix build with pkgconf 1.5.3
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 12 Dec 2018 20:52:06 +0000 (21:52 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:22:17 +0000 (21:22 +0100)
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

bluez5_utils uses the sysconfdir variable from dbus-1.pc to decide where
to install things. Since DESTDIR is prepended to the install
destination, this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the sysconfdir to use
explicitly instead of relying on dbus-1.pc.

Fixes:
 - http://autobuild.buildroot.org/results/498e7e368fbb3d69c2f311e3e5bc213e507b8023

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/bluez5_utils/bluez5_utils.mk

index f5b827cc3080193b649a760c22e872c803647e35..15c9b670a7b26aa0050e976f8e5342b85aed95f5 100644 (file)
@@ -20,7 +20,8 @@ BLUEZ5_UTILS_DEPENDENCIES = \
 BLUEZ5_UTILS_CONF_OPTS = \
        --enable-tools \
        --enable-library \
-       --disable-cups
+       --disable-cups \
+       --with-dbusconfdir=/etc
 
 ifeq ($(BR2_PACKAGE_BLUEZ5_UTILS_OBEX),y)
 BLUEZ5_UTILS_CONF_OPTS += --enable-obex