wireshark: add libxml2 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 4 Nov 2018 10:10:26 +0000 (11:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 6 Nov 2018 23:13:18 +0000 (00:13 +0100)
Optional dependency to libxml2 has been added with version 2.4.0 and
https://github.com/wireshark/wireshark/commit/cfab5ef035db7be8502623af203ab3494a9200e3

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wireshark/wireshark.mk

index d2b3ec4e4e7f152bcd96e0f639a4476920793412..a141ca3e2af5b3aa6e2a0506cfcfc57f59bb42de 100644 (file)
@@ -17,7 +17,6 @@ WIRESHARK_CONF_ENV = \
 WIRESHARK_CONF_OPTS = \
        --enable-static=no \
        --without-bcg729 \
-       --without-libxml2 \
        --without-lz4 \
        --without-nghttp2 \
        --without-snappy \
@@ -96,6 +95,13 @@ else
 WIRESHARK_CONF_OPTS += --without-libssh
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+WIRESHARK_CONF_OPTS += --with-libxml2
+WIRESHARK_DEPENDENCIES += libxml2
+else
+WIRESHARK_CONF_OPTS += --without-libxml2
+endif
+
 # no support for lua53 yet
 ifeq ($(BR2_PACKAGE_LUA_5_1)$(BR2_PACKAGE_LUA_5_2),y)
 WIRESHARK_CONF_OPTS += --with-lua