new package: luacjson
authorDanomi Manchego <danomimanchego123@gmail.com>
Mon, 16 Jul 2012 03:00:27 +0000 (23:00 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Jul 2012 21:30:43 +0000 (23:30 +0200)
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/luacjson/Config.in [new file with mode: 0644]
package/luacjson/luacjson.mk [new file with mode: 0644]

index 5126f1a76ce18a5340dd68d0440fb0467f0a33e6..8529777d931c4c12890ec179d3f174596615051c 100644 (file)
@@ -250,6 +250,7 @@ menu "LUA libraries/modules"
 source "package/cgilua/Config.in"
 source "package/copas/Config.in"
 source "package/coxpcall/Config.in"
+source "package/luacjson/Config.in"
 source "package/luaexpat/Config.in"
 source "package/luafilesystem/Config.in"
 source "package/luasocket/Config.in"
diff --git a/package/luacjson/Config.in b/package/luacjson/Config.in
new file mode 100644 (file)
index 0000000..8a5624f
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_LUACJSON
+       bool "luacjson"
+       help
+         The Lua CJSON module provides JSON support for Lua. It features:
+         - Fast, standards compliant encoding/parsing routines
+         - Full support for JSON with UTF-8, including decoding surrogate pairs
+         - Optional run-time support for common exceptions to the JSON
+           specification (infinity, NaN, ...)
+         - No dependencies on other libraries
+
+         (C-module)
+
+         http://www.kyne.com.au/~mark/software/lua-cjson.php
diff --git a/package/luacjson/luacjson.mk b/package/luacjson/luacjson.mk
new file mode 100644 (file)
index 0000000..fe92f16
--- /dev/null
@@ -0,0 +1,32 @@
+#############################################################
+#
+# luacjson
+#
+#############################################################
+LUACJSON_VERSION      = 2.1.0
+LUACJSON_SOURCE       = lua-cjson-$(LUACJSON_VERSION).tar.gz
+LUACJSON_SITE         = http://www.kyne.com.au/~mark/software/download
+LUACJSON_DEPENDENCIES = lua
+
+define LUACJSON_BUILD_CMDS
+       $(MAKE) -C $(@D) \
+               CFLAGS="$(TARGET_CFLAGS)"   \
+               LDFLAGS="$(TARGET_LDFLAGS)" \
+               CC="$(TARGET_CC)"           \
+               LD="$(TARGET_LD)"           \
+               PREFIX=$(STAGING_DIR)/usr
+endef
+
+define LUACJSON_INSTALL_TARGET_CMDS
+       install -D -m 0644 $(@D)/cjson.so $(TARGET_DIR)/usr/lib/lua/cjson.so
+endef
+
+define LUACJSON_CLEAN_CMDS
+       $(MAKE) -C $(@D) clean
+endef
+
+define LUACJSON_UNINSTALL_TARGET_CMDS
+       rm -f $(TARGET_DIR)/usr/lib/lua/cjson.so
+endef
+
+$(eval $(generic-package))