xapian: new package
authorGilles Talis <gilles.talis@gmail.com>
Sun, 7 Oct 2018 09:17:01 +0000 (11:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 8 Oct 2018 16:07:09 +0000 (18:07 +0200)
Signed-off-by: Gilles Talis <gilles.talis@gmail.com>
[Thomas:
 - add zlib to the DEPENDENCIES variable
 - add missing Config.in comment.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/xapian/Config.in [new file with mode: 0644]
package/xapian/xapian.hash [new file with mode: 0644]
package/xapian/xapian.mk [new file with mode: 0644]

index ab741d4ef56b56e8ab989c73fd45c387ae6a4c52..b4294e2c485e11acf8ddae2fc19dcdbb729bd37a 100644 (file)
@@ -903,6 +903,7 @@ F:  package/leptonica/
 F:     package/ocrad/
 F:     package/tesseract-ocr/
 F:     package/webp/
+F:     package/xapian/
 
 N:     Giulio Benetti <giulio.benetti@micronovasrl.com>
 F:     package/sunxi-mali-mainline/
index 19ee391b3b7bdb93caab093f561965881356a78b..1f3c7e7f4ecef97e3bebe72c3ee71bb7a3ce793f 100644 (file)
@@ -1672,6 +1672,7 @@ endif
        source "package/tinycbor/Config.in"
        source "package/tz/Config.in"
        source "package/tzdata/Config.in"
+       source "package/xapian/Config.in"
 endmenu
 
 menu "Security"
diff --git a/package/xapian/Config.in b/package/xapian/Config.in
new file mode 100644 (file)
index 0000000..5d54ed3
--- /dev/null
@@ -0,0 +1,18 @@
+config BR2_PACKAGE_XAPIAN
+       bool "xapian"
+       depends on BR2_USE_MMU # fork()
+       depends on BR2_INSTALL_LIBSTDCPP
+       select BR2_PACKAGE_ZLIB
+       help
+         Xapian is an open Source search engine Library
+         It is a highly adaptable toolkit which allows developers
+         to easily add advanced indexing and search facilities to
+         their own applications.
+         It has built-in support for several families of weighting
+         models and supports a rich set of boolean query operators.
+
+         https://xapian.org/
+
+comment "xapian needs a toolchain w/ C++"
+       depends on BR2_USE_MMU
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/xapian/xapian.hash b/package/xapian/xapian.hash
new file mode 100644 (file)
index 0000000..4fd0dd1
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256 13f08a0b649c7afa804fa0e85678d693fd6069dd394c9b9e7d41973d74a3b5d3 xapian-core-1.4.7.tar.xz
+sha256 c38aee9e3c8c4d5d594ff548a1be05453023016d6286931f6512db215ec1fd42 COPYING
diff --git a/package/xapian/xapian.mk b/package/xapian/xapian.mk
new file mode 100644 (file)
index 0000000..241f37b
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# xapian
+#
+################################################################################
+
+XAPIAN_VERSION = 1.4.7
+XAPIAN_SOURCE = xapian-core-$(XAPIAN_VERSION).tar.xz
+XAPIAN_SITE = https://oligarchy.co.uk/xapian/$(XAPIAN_VERSION)
+XAPIAN_LICENSE = GPL-2.0+
+XAPIAN_LICENSE_FILES = COPYING
+XAPIAN_INSTALL_STAGING = YES
+XAPIAN_DEPENDENCIES = zlib
+
+$(eval $(autotools-package))