Patch from Lauri Leukkunen adding knobs controlling whether
authorEric Andersen <andersen@codepoet.org>
Fri, 27 Feb 2004 19:26:55 +0000 (19:26 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 27 Feb 2004 19:26:55 +0000 (19:26 -0000)
host binaries are stripped or not

make/gcc-uclibc-2.95.mk
make/gcc-uclibc-3.3.mk

index a896e478c0312df26b6cbecce8530a40e5729b85..9294b53f73e01cdf33dbbe46897eec6670771e34 100644 (file)
@@ -27,6 +27,7 @@ GCC_CAT:=bzcat
 STLPORT_SITE=http://www.stlport.org/archive
 STLPORT_SOURCE=STLport-4.5.3.tar.gz
 STLPORT_DIR=$(TOOL_BUILD_DIR)/STLport-4.5.3
+GCC_STRIP_HOST_BINARIES:=true
 
 #############################################################
 #
@@ -184,7 +185,9 @@ $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
 $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        PATH=$(TARGET_PATH) $(MAKE) $(JLEVEL) -C $(GCC_BUILD_DIR2) install
        # Strip the host binaries
+ifeq ($(GCC_STRIP_HOST_BINARIES),true)
        -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+endif
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(STAGING_DIR); \
index df05de77dc5f98080c7a8af0c06872455798e73e..465f0d50d544622a22903a3cb918124217add75c 100644 (file)
@@ -33,6 +33,7 @@ GCC_SITE:=http://gcc.get-software.com/releases/gcc-$(GCC_VERSION)
 GCC_SOURCE:=gcc-$(GCC_VERSION).tar.bz2
 GCC_DIR:=$(TOOL_BUILD_DIR)/gcc-$(GCC_VERSION)
 GCC_CAT:=bzcat
+GCC_STRIP_HOST_BINARIES:=true
 
 #############################################################
 #
@@ -154,7 +155,9 @@ $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
 $(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
        PATH=$(TARGET_PATH) $(MAKE) $(JLEVEL) -C $(GCC_BUILD_DIR2) install
        # Strip the host binaries
+ifeq ($(GCC_STRIP_HOST_BINARIES),true)
        -strip --strip-all -R .note -R .comment $(STAGING_DIR)/bin/*
+endif
        # Set up the symlinks to enable lying about target name.
        set -e; \
        (cd $(STAGING_DIR); \