grep: bump to version 2.9
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 13 Nov 2011 22:27:56 +0000 (19:27 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 14 Nov 2011 08:33:48 +0000 (09:33 +0100)
Bump grep to version 2.9
Also make it build after busybox if it's enabled, we prefer full-blown
utilities.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/grep/grep.mk

index e8b9cfef20b6757ce627dcfa2dc95ca469d5bfdd..e039135b3ee755b59f297866a4f463e680a4e4d1 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-GREP_VERSION = 2.7
+GREP_VERSION = 2.9
 GREP_SITE = $(BR2_GNU_MIRROR)/grep
 GREP_CONF_OPT = --disable-perl-regexp --without-included-regex
 GREP_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext libintl)
@@ -15,4 +15,9 @@ GREP_CONF_ENV += LIBS=-liconv
 GREP_DEPENDENCIES += libiconv
 endif
 
+# Full grep preferred over busybox grep
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+GREP_DEPENDENCIES += busybox
+endif
+
 $(eval $(call AUTOTARGETS))