- move setting up the extensions to correct place (like i said but tom didn't do..)
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 2 Jun 2007 09:05:40 +0000 (09:05 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 2 Jun 2007 09:05:40 +0000 (09:05 -0000)
Makefile

index d58b693db22b9e9071050d48936cd400a604974b..d8095631975c0cb438661f33e04a4b52e0dc2d49 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -45,43 +45,28 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 cc-option = $(shell if $(TARGET_CC) $(TARGET_CFLAGS) $(1) -S -o /dev/null -xc /dev/null \
        > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
 
-#############################################################
-#
-# The list of stuff to build for the target toolchain
-# along with the packages to build for the target.
-#
-##############################################################
-ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
-TARGETS:=uclibc-configured binutils gcc uclibc-target-utils
-else
-TARGETS:=uclibc
-endif
-include toolchain/Makefile.in
-include package/Makefile.in
 
 #############################################################
 #
-# You should probably leave this stuff alone unless you know
-# what you are doing.
+# Setup the proper filename extensions for the target
 #
-#############################################################
-
-ifneq (,$(findstring linux,$(BR2_GNU_BUILD_SUFFIX)))
+##############################################################
+ifneq ($(findstring linux,$(BR2_GNU_BUILD_SUFFIX)),)
 EXEEXT:=
 LIBEXT:=.a
 SHREXT:=.so
 endif
-ifneq (,$(findstring apple,$(BR2_GNU_BUILD_SUFFIX)))
+ifneq ($(findstring apple,$(BR2_GNU_BUILD_SUFFIX)),)
 EXEEXT:=
 LIBEXT:=.a
 SHREXT:=.dylib
 endif
-ifneq (,$(findstring cygwin,$(BR2_GNU_BUILD_SUFFIX)))
+ifneq ($(findstring cygwin,$(BR2_GNU_BUILD_SUFFIX)),)
 EXEEXT:=.exe
 LIBEXT:=.lib
 SHREXT:=.dll
 endif
-ifneq (,$(findstring mingw,$(BR2_GNU_BUILD_SUFFIX)))
+ifneq ($(findstring mingw,$(BR2_GNU_BUILD_SUFFIX)),)
 EXEEXT:=.exe
 LIBEXT:=.lib
 SHREXT:=.dll
@@ -93,6 +78,29 @@ else
 LIBTGTEXT=$(SHREXT)
 endif
 
+
+
+#############################################################
+#
+# The list of stuff to build for the target toolchain
+# along with the packages to build for the target.
+#
+##############################################################
+ifeq ($(BR2_TOOLCHAIN_BUILDROOT),y)
+TARGETS:=uclibc-configured binutils gcc uclibc-target-utils
+else
+TARGETS:=uclibc
+endif
+include toolchain/Makefile.in
+include package/Makefile.in
+
+#############################################################
+#
+# You should probably leave this stuff alone unless you know
+# what you are doing.
+#
+#############################################################
+
 all:   world
 
 # In this section, we need .config