package/opkg-utils: needs Python3 on the host
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Wed, 9 Dec 2020 15:15:50 +0000 (16:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 21 Dec 2020 09:26:06 +0000 (10:26 +0100)
The 'opkg.py' script installed by host-opkg-utils has as shebang:
    #!/usr/bin/env python3

which may not be available on all host machines.
Add a potential dependency on host-python3 via BR2_PYTHON3_HOST_DEPENDENCY,
which will only add the host-python3 dependency if no python3 is already
available on the host.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/opkg-utils/opkg-utils.mk

index fa14053f65ebaa50b133b5a2c2758b65cde42b2c..a94a4cd5cdafd803a295802662d9d7663ae02383 100644 (file)
@@ -10,6 +10,8 @@ OPKG_UTILS_SITE_METHOD = git
 OPKG_UTILS_LICENSE = GPL-2.0+
 OPKG_UTILS_LICENSE_FILES = COPYING
 
+HOST_OPKG_UTILS_DEPENDENCIES += $(BR2_PYTHON3_HOST_DEPENDENCY)
+
 define HOST_OPKG_UTILS_BUILD_CMDS
        $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS)
 endef