- remove BR2_TAR_VERBOSITY and add helptext to BR2_TAR_OPTIONS.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Dec 2005 15:36:43 +0000 (15:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 10 Dec 2005 15:36:43 +0000 (15:36 -0000)
  default to no additional tar options.

Config.in
Makefile

index f62f9c9733c138c1f9c29044042aaf5d4b270d0c..db5c84b4aa0d0eeea9ca04b22113c5110c74a306 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -121,13 +121,13 @@ config BR2_SVN
        string "Subversion (svn) checkout command"
        default "svn co"
 
-config BR2_TAR_VERBOSITY
-       bool "Tar verbose"
-       default n
-
 config BR2_TAR_OPTIONS
        string "Tar options"
-       default "--exclude='.svn'"
+       default ""
+       help
+         Options to pass to tar when extracting the sources.
+         E.g. " -v --exclude='*.svn*'" to exclude all .svn internal files
+         and to be verbose.
 
 config BR2_DL_DIR
        string "Download dir"
index 629129603bb3480b47675619d3462586ea18c421..1f52a15eba56e1c9d98c300ae27aa6f93e9da4d1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -35,13 +35,8 @@ ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 -include $(TOPDIR).config
 endif
 
-ifeq ($(BR2_TAR_VERBOSITY),y)
-TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xvf
-#"
-else
 TAR_OPTIONS=$(subst ",, $(BR2_TAR_OPTIONS)) -xf
 #"
-endif
 
 ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)