autotools: fix autoreconf check
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 28 Apr 2010 21:40:42 +0000 (23:40 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 2 May 2010 21:24:21 +0000 (23:24 +0200)
The autoreconf check was incorrect, missing a $ sign to properly
reference a package-specific variable. There was no visible effect
until now since :

 * The existing syntax allowed to access the value defined in the
   package specific .mk file, so when AUTORECONF was set to YES by a
   package, it was working.

 * The default value in Makefile.autotools.in was NO. In fact, when a
   package .mkf file wasn't defining the AUTORECONF variable, the
   Makefile.autotools.in test was testing the empty string against
   'YES', which was false, leading to the AUTORECONF not being done,
   which was the desired effect.

However, in a later patch, we intend to change this default value.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Makefile.autotools.in

index b7a71035946b51b12c1580e724af7d736e423b53..fc5bcee343fde41003d9d0c08b77aa6489f273d8 100644 (file)
@@ -162,7 +162,7 @@ define AUTORECONF_HOOK
        fi
 endef
 
-ifeq ($($(2)_AUTORECONF),YES)
+ifeq ($$($(2)_AUTORECONF),YES)
 $(2)_POST_PATCH_HOOKS += AUTORECONF_HOOK
 $(2)_DEPENDENCIES += host-automake host-autoconf host-libtool
 endif