qt5connectivity: add bluez5_utils option for QtBluetooth submodule
authorJulien CORJON <corjon.j@ecagroup.com>
Tue, 19 Apr 2016 11:43:54 +0000 (13:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 17:43:27 +0000 (19:43 +0200)
Signed-off-by: Julien Corjon <corjon.j@ecagroup.com>
[Thomas: simplify ifneq conditions in the .mk file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5connectivity/Config.in
package/qt5/qt5connectivity/qt5connectivity.mk

index e3128ec55c133e9ce6be3af5adc82e72fbaa2110..fa9b9112c6917dc5f8706ef1536d024669029c12 100644 (file)
@@ -3,7 +3,7 @@ config BR2_PACKAGE_QT5CONNECTIVITY
        select BR2_PACKAGE_QT5BASE
        select BR2_PACKAGE_QT5BASE_CONCURRENT
        select BR2_PACKAGE_QT5BASE_DBUS
-       depends on BR2_PACKAGE_NEARD || BR2_PACKAGE_BLUEZ_UTILS
+       depends on BR2_PACKAGE_NEARD || BR2_PACKAGE_BLUEZ_UTILS || BR2_PACKAGE_BLUEZ5_UTILS
        help
          Qt is a cross-platform application and UI framework for
          developers using C++.
@@ -12,5 +12,6 @@ config BR2_PACKAGE_QT5CONNECTIVITY
 
          http://qt.io
 
-comment "qt5connectivity needs neard and/or bluez_utils"
-       depends on !BR2_PACKAGE_NEARD && !BR2_PACKAGE_BLUEZ_UTILS
+comment "qt5connectivity needs neard and/or bluez(5)_utils"
+       depends on !BR2_PACKAGE_NEARD && !BR2_PACKAGE_BLUEZ_UTILS && \
+               !BR2_PACKAGE_BLUEZ5_UTILS
index ac0f2dd765a6dede0d953381ec2b05230172cc71..0f7257d3906e2bfc4cfb81eb61a760a9fb8c47dd 100644 (file)
@@ -20,6 +20,7 @@ endif
 
 QT5CONNECTIVITY_DEPENDENCIES += $(if $(BR2_PACKAGE_QT5DECLARATIVE),qt5declarative)
 QT5CONNECTIVITY_DEPENDENCIES += $(if $(BR2_PACKAGE_BLUEZ_UTILS),bluez_utils)
+QT5CONNECTIVITY_DEPENDENCIES += $(if $(BR2_PACKAGE_BLUEZ5_UTILS),bluez5_utils)
 QT5CONNECTIVITY_DEPENDENCIES += $(if $(BR2_PACKAGE_NEARD),neard)
 
 define QT5CONNECTIVITY_CONFIGURE_CMDS
@@ -36,7 +37,7 @@ define QT5CONNECTIVITY_INSTALL_STAGING_CMDS
 endef
 
 ifeq ($(BR2_PACKAGE_QT5DECLARATIVE_QUICK),y)
-ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+ifneq ($(BR2_PACKAGE_BLUEZ_UTILS)$(BR2_PACKAGE_BLUEZ5_UTILS),)
 define QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH_QMLS
        cp -dpfr $(STAGING_DIR)/usr/qml/QtBluetooth $(TARGET_DIR)/usr/qml/
 endef
@@ -48,7 +49,7 @@ endef
 endif
 endif
 
-ifeq ($(BR2_PACKAGE_BLUEZ_UTILS),y)
+ifneq ($(BR2_PACKAGE_BLUEZ_UTILS)$(BR2_PACKAGE_BLUEZ5_UTILS),)
 define QT5CONNECTIVITY_INSTALL_TARGET_BLUETOOTH
        cp -dpf $(STAGING_DIR)/usr/lib/libQt5Bluetooth.so.* $(TARGET_DIR)/usr/lib
        cp -dpf $(STAGING_DIR)/usr/bin/sdpscanner $(TARGET_DIR)/usr/bin