package/go-bootstrap: Set CGO_ENABLED=0
authorGeoff Levand <geoff@infradead.org>
Thu, 12 May 2016 00:08:46 +0000 (00:08 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 12 May 2016 14:09:43 +0000 (16:09 +0200)
Fixes build erorros like these:

  cgo.a(_all.o): unknown relocation type 42; compiled without -fpic?

Signed-off-by: Geoff Levand <geoff@infradead.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/go-bootstrap/go-bootstrap.mk

index fd236289411e75e13573ae8942c3a441f119b70f..47f5013232f38186dd3635f08bf1dddde077cbf4 100644 (file)
@@ -23,7 +23,8 @@ HOST_GO_BOOTSTRAP_MAKE_ENV = \
        GOOS=linux \
        GOROOT_FINAL="$(HOST_GO_BOOTSTRAP_ROOT)" \
        GOROOT="$(@D)" \
-       GOBIN="$(@D)/bin"
+       GOBIN="$(@D)/bin" \
+       CGO_ENABLED=0
 
 define HOST_GO_BOOTSTRAP_BUILD_CMDS
        cd $(@D)/src && $(HOST_GO_BOOTSTRAP_MAKE_ENV) ./make.bash