package/qemu: use a system-wide slirp
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 12 Nov 2020 22:00:59 +0000 (23:00 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Nov 2020 17:25:49 +0000 (18:25 +0100)
Use a system-wide slirp now that we switched to the up to date
https://gitlab.freedesktop.org/slirp/libslirp

qemu already depends on libglib2 so we don't need to add any new
dependencies

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/qemu/Config.in
package/qemu/qemu.mk

index 33d4cccd7b46aa96b8a7bc9cbeaff9b5c122b942..391fd5faaf22efae96bec5c20caa9465423037cb 100644 (file)
@@ -58,6 +58,7 @@ comment "Networking options"
 
 config BR2_PACKAGE_QEMU_SLIRP
        bool "Enable user mode networking (SLIRP)"
+       select BR2_PACKAGE_SLIRP
        help
          Enable user mode network stack, which is the default
          networking backend. It requires no administrator privileges
index 69850ec9383fbec0db5b85c96610a83705465676..2bac96bd66a128decb71256ec90505549a8cb02f 100644 (file)
@@ -51,8 +51,10 @@ endif
 
 endif
 
-# There is no "--enable-slirp"
-ifeq ($(BR2_PACKAGE_QEMU_SLIRP),)
+ifeq ($(BR2_PACKAGE_QEMU_SLIRP),y)
+QEMU_OPTS += --enable-slirp=system
+QEMU_DEPENDENCIES += slirp
+else
 QEMU_OPTS += --disable-slirp
 endif