gauche: explicitly handle zlib
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Nov 2015 12:14:26 +0000 (13:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 5 Nov 2015 12:14:26 +0000 (13:14 +0100)
host-gauche currently fails to build if host-zlib was built before,
because it finds zlib.h, but due to issues in gauche's build system,
the LDFLAGS passed in the configure script (with -L
$(HOST_DIR)/usr/lib) are not passed all the way down to where -lz is
used, causing a build failure.

Since we don't need zlib support in host-gauche, we simply disable it
explicitly.

While we're at it, we make the optional dependency on zlib explicit
for the target variant of the gauche package.

Fixes:

   http://autobuild.buildroot.org/results/426/4269c465312ddcc801289914fa29427798ef7783/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gauche/gauche.mk

index c0563b2930a869153fbf54cd2e8d03368587257b..b887c6acfe1007e6c61a0a752e4fe246a84fbbbd 100644 (file)
@@ -11,6 +11,15 @@ GAUCHE_LICENSE = BSD-3c, Boehm-gc, SRFI (srfi-11.scm), reload (reload.scm)
 GAUCHE_LICENSE_FILES = COPYING
 GAUCHE_DEPENDENCIES = host-gauche
 
+HOST_GAUCHE_CONF_OPTS = --without-zlib
+
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+GAUCHE_CONF_OPTS += --with-zlib=$(STAGING_DIR)
+GAUCHE_DEPENDENCIES += zlib
+else
+GAUCHE_CONF_OPTS += --without-zlib
+endif
+
 # Detection of c99 support in configure fails without WCHAR. To enable
 # automatic detection of c99 support by configure, we need to enable
 # WCHAR in toolchain. But actually we do not need WCHAR at gauche