gst-ffmpeg: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Mon, 20 Jan 2014 10:33:40 +0000 (12:33 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 20 Jan 2014 21:23:37 +0000 (22:23 +0100)
Since commit 6ea49a23df3 (gst-ffmpeg: Use internal libav instead of external
ffmpeg) gst-ffmpge uses its internal libav. This requires the same fix for
xtensa like ffmpeg got in commit 4ec35e76b8a3 (ffmpeg: fix build for xtensa).

Fixes
http://autobuild.buildroot.net/results/08a/08a27891fd5336250f00e611a15ea45505985f67/.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gstreamer/gst-ffmpeg/gst-ffmpeg.mk

index 6534f9310795d250a26840b5e19ca4bcb664bfad..eb7389f90f305e3f7a3dbe854f71fa5367f09c47 100644 (file)
@@ -14,6 +14,14 @@ GST_FFMPEG_CONF_EXTRA_OPT = \
                --cross-prefix=$(TARGET_CROSS) \
                --target-os=linux
 
+GST_FFMPEG_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_xtensa),y)
+GST_FFMPEG_CFLAGS += -mtext-section-literals
+endif
+
+GST_FFMPEG_CONF_ENV = CFLAGS="$(GST_FFMPEG_CFLAGS)"
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 GST_FFMPEG_CONF_EXTRA_OPT += --enable-zlib
 GST_FFMPEG_DEPENDENCIES += zlib