package/tinyxml2: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 1 Apr 2015 18:35:55 +0000 (20:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Apr 2015 21:37:04 +0000 (23:37 +0200)
Required for upcoming kodi-pvr-dvblink package:
https://github.com/kodi-pvr/pvr.dvblink/blob/master/CMakeLists.txt#L11

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/tinyxml2/Config.in [new file with mode: 0644]
package/tinyxml2/tinyxml2.mk [new file with mode: 0644]

index cee013e096b3fe168c9a5c57de991125578a6300..afa145eefefd74b4152e157f3d519884ee5bef58 100644 (file)
@@ -878,6 +878,7 @@ menu "JSON/XML"
        source "package/mxml/Config.in"
        source "package/rapidjson/Config.in"
        source "package/tinyxml/Config.in"
+       source "package/tinyxml2/Config.in"
        source "package/xerces/Config.in"
        source "package/yajl/Config.in"
        source "package/yaml-cpp/Config.in"
diff --git a/package/tinyxml2/Config.in b/package/tinyxml2/Config.in
new file mode 100644 (file)
index 0000000..25bc594
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_TINYXML2
+       bool "tinyxml2"
+       depends on BR2_INSTALL_LIBSTDCPP
+       help
+         TinyXML-2 is a simple, small, efficient, C++ XML parser that can be
+         easily integrating into other programs.
+
+         http://www.grinninglizard.com/tinyxml2/index.html
+
+comment "tinyxml2 needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/tinyxml2/tinyxml2.mk b/package/tinyxml2/tinyxml2.mk
new file mode 100644 (file)
index 0000000..370049b
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# tinyxml2
+#
+################################################################################
+
+TINYXML2_VERSION = 2.2.0
+TINYXML2_SITE = $(call github,leethomason,tinyxml2,$(TINYXML2_VERSION))
+TINYXML2_LICENSE = zlib
+TINYXML2_LICENSE_FILES = readme.md
+TINYXML2_INSTALL_STAGING = YES
+
+$(eval $(cmake-package))