Remove --without-html-dir from DISABLE_DOCUMENTATION
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Aug 2009 18:21:58 +0000 (20:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 8 Aug 2009 18:21:58 +0000 (20:21 +0200)
In an attempt to disable the compilation and installation of
documentation of gtk packages, a DISABLE_DOCUMENTATION variable
containing --without-html-dir has been added to
package/Makefile.in. This variable is used by
package/Makefile.autotools.in so that --without-html-dir is in effect
passed to all autotools-based packaging relying on the
Makefile.autotools.in infrastructure.

Unfortunately, --without-html-dir doesn't work. It leads libglib2
./configure script to think that HTML_DIR is "no", which leads to the
installation of the documentation in $(STAGING_DIR)no (yes, with the
"no" suffix at the end). The issue is that --with-html-dir is not an
enable/disable type of option, it's an option that only allows to pass
a PATH for documentation installation.

As we don't want the documentation to be installed in this odd
$(STAGING_DIR)no directory, we simply get rid of this option.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in

index 0829e8f3bb09eaea78792c0fca9329083a862862..2dbf37fbf7b6f9feb1a6689c6b7765f6cee3cb12 100644 (file)
@@ -354,7 +354,7 @@ DISABLE_LARGEFILE= --disable-largefile
 endif
 
 ifneq ($(BR2_HAVE_DOCUMENTATION),y)
-DISABLE_DOCUMENTATION=--without-html-dir --disable-gtk-doc
+DISABLE_DOCUMENTATION=--disable-gtk-doc
 endif
 
 ifneq ($(BR2_INET_IPV6),y)