avahi: add optional dbus-python support
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Dec 2014 16:15:01 +0000 (17:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Dec 2014 22:48:53 +0000 (23:48 +0100)
Without this, the python support doesn't do anything.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/avahi/avahi.mk

index 4e5dbc669d62368284c6cd9c4b8145a382e88081..e42f78d7c8593fb79f959cdf87d57e25524252e0 100644 (file)
@@ -71,7 +71,6 @@ AVAHI_CONF_OPTS = \
                --disable-qt3 \
                --disable-qt4 \
                --disable-gdbm \
-               --disable-python-dbus \
                --disable-pygtk \
                --disable-mono \
                --disable-monodoc \
@@ -144,6 +143,14 @@ else
 AVAHI_CONF_OPTS += --disable-python
 endif
 
+ifeq ($(BR2_PACKAGE_DBUS_PYTHON),y)
+AVAHI_CONF_OPTS += --enable-python-dbus
+AVAHI_CONF_ENV  += py_cv_mod_dbus_=yes
+AVAHI_DEPENDENCIES += dbus-python
+else
+AVAHI_CONF_OPTS += --disable-python-dbus
+endif
+
 AVAHI_MAKE_OPTS += $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),LIBS=-lintl)
 
 define AVAHI_USERS