package/file: add xz optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 31 Jan 2020 18:05:43 +0000 (19:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 1 Feb 2020 09:27:21 +0000 (10:27 +0100)
xz is an optional dependency since version 5.38 and
https://github.com/file/file/commit/b259a07ea95827f565faa20f0316e5b2704064f7

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/file/file.mk

index 3ae7c8597671af3a60af71ffbc72e60c33a96e04..8d0968e6b2dbe6351241570039179e0db2d6cc39 100644 (file)
@@ -21,5 +21,12 @@ else
 FILE_CONF_OPTS += --disable-libseccomp
 endif
 
+ifeq ($(BR2_PACKAGE_XZ),y)
+FILE_CONF_OPTS += --enable-xzlib
+FILE_DEPENDENCIES += xz
+else
+FILE_CONF_OPTS += --disable-xzlib
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))