rsyslog: install systemd services links
authorThierry Bultel <tbultel@free.fr>
Fri, 12 Dec 2014 22:39:56 +0000 (23:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Dec 2014 22:41:16 +0000 (23:41 +0100)
Signed-off-by: Thierry Bultel <tbultel@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rsyslog/rsyslog.mk

index 6b72bb515cd66a7b0cbfb108b65d5a18a3141c4a..688a335694c151de24e04bce87da89b4c87906f3 100644 (file)
@@ -43,6 +43,14 @@ define RSYSLOG_INSTALL_INIT_SYSV
                $(TARGET_DIR)/etc/init.d/S01rsyslog
 endef
 
+define RSYSLOG_INSTALL_INIT_SYSTEMD
+       ln -sf /lib/systemd/system/rsyslog.service \
+               $(TARGET_DIR)/etc/systemd/system/syslog.service
+       mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
+       ln -sf ../syslog.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/syslog.service
+endef
+
 define RSYSLOG_INSTALL_CONF
        $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
                $(TARGET_DIR)/etc/rsyslog.conf