perl-x10: new package
authorChristopher McCrory <chrismcc@gmail.com>
Mon, 20 Aug 2018 11:55:06 +0000 (04:55 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Sep 2018 20:29:14 +0000 (22:29 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-x10/Config.in [new file with mode: 0644]
package/perl-x10/perl-x10.hash [new file with mode: 0644]
package/perl-x10/perl-x10.mk [new file with mode: 0644]

index 5c9d7fa6169f84d5f7a81fe6867ba2cd5a0e9dcf..6db07e1ada199fc19adb466f3932d485529b2b9e 100644 (file)
@@ -509,6 +509,7 @@ F:  package/perl-sub-install/
 F:     package/perl-sys-meminfo/
 F:     package/perl-sys-mmap/
 F:     package/perl-time-parsedate/
+F:     package/perl-x10/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index f0a02d14a8f2b1280d9c609295a33940a8dc41d5..bae9ed02b3cdefca0a75c4e8b0ebf403c028a52f 100644 (file)
@@ -737,6 +737,7 @@ menu "Perl libraries/modules"
        source "package/perl-try-tiny/Config.in"
        source "package/perl-uri/Config.in"
        source "package/perl-www-robotrules/Config.in"
+       source "package/perl-x10/Config.in"
        source "package/perl-xml-libxml/Config.in"
        source "package/perl-xml-namespacesupport/Config.in"
        source "package/perl-xml-sax/Config.in"
diff --git a/package/perl-x10/Config.in b/package/perl-x10/Config.in
new file mode 100644 (file)
index 0000000..984a561
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_PERL_X10
+       bool "perl-x10"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PERL_ASTRO_SUNTIME
+       select BR2_PACKAGE_PERL_DEVICE_SERIALPORT
+       select BR2_PACKAGE_PERL_TIME_PARSEDATE
+       help
+         creates a server used to receive events from an x10 client
+
+         https://metacpan.org/release/X10
+
+comment "perl-x10 needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-x10/perl-x10.hash b/package/perl-x10/perl-x10.hash
new file mode 100644 (file)
index 0000000..5411390
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    20dcca2dfb978bfed3043276aa3481e5 X10-0.04.tar.gz
+sha256 3dcee9d95614b2db70de608e933d42817f93fccd5b1f2f782b0846af487d9134 X10-0.04.tar.gz
+
+# computed by scancpan
+sha256 e6f320afa82517d663be348dd2515ecb1454a7c851ba5590f13aca01d219be80 README
diff --git a/package/perl-x10/perl-x10.mk b/package/perl-x10/perl-x10.mk
new file mode 100644 (file)
index 0000000..8f091b9
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-x10
+#
+################################################################################
+
+PERL_X10_VERSION = 0.04
+PERL_X10_SOURCE = X10-$(PERL_X10_VERSION).tar.gz
+PERL_X10_SITE = $(BR2_CPAN_MIRROR)/authors/id/R/RO/ROBF
+PERL_X10_DEPENDENCIES = perl-astro-suntime perl-device-serialport perl-time-parsedate
+PERL_X10_LICENSE = GPL-3.0
+PERL_X10_LICENSE_FILES = README
+
+$(eval $(perl-package))