package/asterisk: add optional libsrtp dependency
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 9 Sep 2017 21:39:25 +0000 (23:39 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 23 Sep 2017 17:20:18 +0000 (19:20 +0200)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/asterisk/asterisk.mk

index f5efdfaabbe0f30354c87487e0f217314a876e3c..e674565db1c1fd55125be1084eac9d2bd09ffe76 100644 (file)
@@ -90,7 +90,6 @@ ASTERISK_CONF_OPTS = \
        --without-spandsp \
        --without-ss7 \
        --without-sqlite \
-       --without-srtp \
        --without-suppserv \
        --without-tds \
        --without-termcap \
@@ -211,6 +210,13 @@ else
 ASTERISK_CONF_OPTS += --without-speex  --without-speexdsp
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSRTP),y)
+ASTERISK_DEPENDENCIES += libsrtp
+ASTERISK_CONF_OPTS += --with-srtp
+else
+ASTERISK_CONF_OPTS += --without-srtp
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVORBIS),y)
 ASTERISK_DEPENDENCIES += libvorbis
 ASTERISK_CONF_OPTS += --with-vorbis