neon: remove neon-config script from TARGET_DIR
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Dec 2010 17:22:02 +0000 (18:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 7 Mar 2011 21:22:31 +0000 (22:22 +0100)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/neon/neon.mk

index c570fc1dac298a55f5e9b6c29eac58192381286a..0c237dcaf5cb6ebeabc6fd6c88c7802275f0a733 100644 (file)
@@ -45,4 +45,12 @@ else
 NEON_CONF_OPT+=--without-ssl
 endif
 
+define NEON_REMOVE_CONFIG_SCRIPTS
+       $(RM) -f $(TARGET_DIR)/usr/bin/neon-config
+endef
+
+ifneq ($(BR2_HAVE_DEVFILES),y)
+NEON_POST_INSTALL_TARGET_HOOKS += NEON_REMOVE_CONFIG_SCRIPTS
+endif
+
 $(eval $(call AUTOTARGETS,package,neon))