Fix avahi compile when libexpat is not selected
authorThiago A. Corrêa <thiago.correa@gmail.com>
Tue, 24 Jun 2008 16:02:22 +0000 (16:02 -0000)
committerThiago A. Corrêa <thiago.correa@gmail.com>
Tue, 24 Jun 2008 16:02:22 +0000 (16:02 -0000)
package/avahi/avahi.mk

index 46532a35d0fc97393cbc53752fa93c49b5baba55..5f14beea6953cef534beaa2fa948873c9f4fa801 100644 (file)
@@ -26,12 +26,12 @@ AVAHI_EXTRA_DEPS:=
 
 ifeq ($(strip $(BR2_PACKAGE_AVAHI_DAEMON)),y)
 AVAHI_TARGETS+=$(TARGET_DIR)/usr/sbin/avahi-daemon
-AVAHI_DISABLE_EXPAT:=
+AVAHI_DISABLE_EXPAT:=--with-xml=expat
 # depend on the exact library file instead of expat so avahi isn't always
 # considered out-of-date
 AVAHI_EXTRA_DEPS+=$(STAGING_DIR)/usr/lib/libexpat.so.1
 else
-AVAHI_DISABLE_EXPAT:=--disable-expat
+AVAHI_DISABLE_EXPAT:=--disable-expat --with-xml=none
 
 endif