wpa_supplicant: modify .config rework order
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 27 Feb 2014 20:47:09 +0000 (17:47 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Mar 2014 15:41:47 +0000 (16:41 +0100)
Switch to first enable and then disable.
Otherwise a wildcard enable can't have a single option disabled which is
far more usual than the opposite (and required for a simple bump to
version 2.1).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wpa_supplicant/wpa_supplicant.mk

index d2b21c292303ab312810e0ef337952ea752cc120..34e8e1fe950a578fdf9bf6e7d42d64eeef74130f 100644 (file)
@@ -106,8 +106,8 @@ endif
 
 define WPA_SUPPLICANT_CONFIGURE_CMDS
        cp $(@D)/wpa_supplicant/defconfig $(WPA_SUPPLICANT_CONFIG)
-       sed -i $(patsubst %,-e 's/^\(%\)/#\1/',$(WPA_SUPPLICANT_CONFIG_DISABLE)) \
-              $(patsubst %,-e 's/^#\(%\)/\1/',$(WPA_SUPPLICANT_CONFIG_ENABLE)) \
+       sed -i $(patsubst %,-e 's/^#\(%\)/\1/',$(WPA_SUPPLICANT_CONFIG_ENABLE)) \
+              $(patsubst %,-e 's/^\(%\)/#\1/',$(WPA_SUPPLICANT_CONFIG_DISABLE)) \
               $(patsubst %,-e '1i%=y',$(WPA_SUPPLICANT_CONFIG_SET)) \
               $(patsubst %,-e %,$(WPA_SUPPLICANT_CONFIG_EDITS)) \
               $(WPA_SUPPLICANT_CONFIG)