heirloom-mailx: new package
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Apr 2012 05:46:56 +0000 (05:46 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Apr 2012 18:01:22 +0000 (20:01 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/heirloom-mailx/Config.in [new file with mode: 0644]
package/heirloom-mailx/heirloom-mailx.mk [new file with mode: 0644]

index 34570beb1cb405971310ec911f7fa59cf461939d..7d145c3103a14e8f606abe75d804b8e15fe2f0ab 100644 (file)
@@ -460,6 +460,7 @@ source "package/dnsmasq/Config.in"
 source "package/dropbear/Config.in"
 source "package/ebtables/Config.in"
 source "package/ethtool/Config.in"
+source "package/heirloom-mailx/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/hiawatha/Config.in"
 endif
diff --git a/package/heirloom-mailx/Config.in b/package/heirloom-mailx/Config.in
new file mode 100644 (file)
index 0000000..9a871d4
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_HEIRLOOM_MAILX
+       bool "heirloom-mailx"
+       help
+         Heirloom mailx (previously known as nail) is a mail user
+         agent for Unix systems.
+
+         It can be used as a command-line mail reader, but also more
+         importantly on embedded systems, as a mail composition
+         program and SMTP client, in order to send e-mail from shell
+         scripts. It supports SMTP authentication (login, plain,
+         cram-md5), SMTPS, MIME encoding of attachements, and more.
+
+         http://heirloom.sourceforge.net/mailx.html
diff --git a/package/heirloom-mailx/heirloom-mailx.mk b/package/heirloom-mailx/heirloom-mailx.mk
new file mode 100644 (file)
index 0000000..2b28a3f
--- /dev/null
@@ -0,0 +1,28 @@
+#############################################################
+#
+# heirloom-mailx
+#
+#############################################################
+
+HEIRLOOM_MAILX_VERSION = 12.5
+HEIRLOOM_MAILX_SOURCE  = heirloom-mailx_$(HEIRLOOM_MAILX_VERSION).orig.tar.gz
+HEIRLOOM_MAILX_SITE    = http://snapshot.debian.org/archive/debian/20110427T035506Z/pool/main/h/heirloom-mailx/
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+HEIRLOOM_MAILX_DEPENDENCIES += openssl
+endif
+
+define HEIRLOOM_MAILX_BUILD_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define HEIRLOOM_MAILX_INSTALL_TARGET_CMDS
+       $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) \
+               PREFIX=/usr \
+               UCBINSTALL=$(INSTALL) \
+               STRIP=/bin/true \
+               DESTDIR=$(TARGET_DIR) \
+               install
+endef
+
+$(eval $(call GENTARGETS))