ttcp: remove deprecated package
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Tue, 21 Jan 2014 07:54:10 +0000 (08:54 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 21 Jan 2014 20:57:20 +0000 (21:57 +0100)
Since this is the only package depending on BR2_DEPRECATED_SINCE_2012_05,
remove that symbol as well.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in
Config.in.legacy
package/Config.in
package/ttcp/Config.in [deleted file]
package/ttcp/ttcp-0001-replace-deprecated-bcopy.patch [deleted file]
package/ttcp/ttcp.mk [deleted file]

index 93d8fcede6be77f44cf6742e9e729ab2b7de44e2..fa723fe0a0efbb7e77e0e9b5c9bb0f7de098ff38 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -268,10 +268,6 @@ config BR2_DEPRECATED_SINCE_2010_11
        bool
        default y
 
-config BR2_DEPRECATED_SINCE_2012_05
-       bool
-       default y
-
 config BR2_DEPRECATED_SINCE_2012_11
        bool
        default y
index 2fed2d87921da93a82f7a0ff22c9d38417d711b5..473d0efee203f1437e555674c33ad2cfa714117e 100644 (file)
@@ -101,6 +101,13 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.02"
 
+config BR2_PACKAGE_TTCP
+       bool "ttcp has been removed"
+       select BR2_LEGACY
+       help
+         The 'ttcp' package has been removed since it has been
+         deprecated for more than four buildroot releases.
+
 config BR2_PACKAGE_LIBNFC_LLCP
        bool "libnfc-llcp has been removed"
        depends on BR2_TOOLCHAIN_HAS_THREADS # libusb
index cd869d840b9ce3853209b19ce5ae51cadf0571bb..ed31354205ff63f9d3147a84e297ddd786ce765c 100644 (file)
@@ -935,7 +935,6 @@ source "package/thttpd/Config.in"
 source "package/tinyhttpd/Config.in"
 source "package/tn5250/Config.in"
 source "package/transmission/Config.in"
-source "package/ttcp/Config.in"
 source "package/tvheadend/Config.in"
 source "package/udpcast/Config.in"
 source "package/ulogd/Config.in"
diff --git a/package/ttcp/Config.in b/package/ttcp/Config.in
deleted file mode 100644 (file)
index 53b1c32..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_TTCP
-       bool "ttcp"
-       depends on BR2_DEPRECATED_SINCE_2012_05
-       help
-         Benchmarking tool for determining TCP and UDP performance.
-
-         ftp://ftp.sgi.com/sgi/src/ttcp/README
diff --git a/package/ttcp/ttcp-0001-replace-deprecated-bcopy.patch b/package/ttcp/ttcp-0001-replace-deprecated-bcopy.patch
deleted file mode 100644 (file)
index fb8ef7f..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-Replace deprecated bcopy call by using memmove instead.
-
-Index: b/ttcp.c
-===================================================================
---- a/ttcp.c
-+++ b/ttcp.c
-@@ -241,7 +241,7 @@
-                       if ((addr=gethostbyname(host)) == NULL)
-                               err("bad hostname");
-                       sinhim.sin_family = addr->h_addrtype;
--                      bcopy(addr->h_addr,(char*)&addr_tmp, addr->h_length);
-+                      memmove((char*)&addr_tmp, addr->h_addr, addr->h_length);
- #if defined(cray)
-                       sinhim.sin_addr = addr_tmp;
- #else
diff --git a/package/ttcp/ttcp.mk b/package/ttcp/ttcp.mk
deleted file mode 100644 (file)
index 7667b20..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-################################################################################
-#
-# ttcp
-#
-################################################################################
-
-TTCP_VERSION = 1.12
-TTCP_SITE    = ftp://ftp.sgi.com/sgi/src/ttcp/
-TTCP_SOURCE  = ttcp.c
-TTCP_LICENSE = public domain
-
-define TTCP_EXTRACT_CMDS
-       cp -f -t $(@D) $(DL_DIR)/$(TTCP_SOURCE)
-endef
-
-define TTCP_BUILD_CMDS
-       $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) \
-               -o $(@D)/ttcp $(@D)/$(TTCP_SOURCE)
-endef
-
-define TTCP_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/ttcp $(TARGET_DIR)/usr/bin/ttcp
-endef
-
-$(eval $(generic-package))