nodejs: security bump to version 8.11.1
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Mar 2018 06:11:55 +0000 (08:11 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Mar 2018 15:09:42 +0000 (17:09 +0200)
Fixes the following security issues:

- Fix for inspector DNS rebinding vulnerability (CVE-2018-7160): A malicious
  website could use a DNS rebinding attack to trick a web browser to bypass
  same-origin-policy checks and allow HTTP connections to localhost or to
  hosts on the local network, potentially to an open inspector port as a
  debugger, therefore gaining full code execution access.  The inspector now
  only allows connections that have a browser Host value of localhost or
  localhost6.

- Fix for 'path' module regular expression denial of service
  (CVE-2018-7158): A regular expression used for parsing POSIX paths could
  be used to cause a denial of service if an attacker were able to have a
  specially crafted path string passed through one of the impacted 'path'
  module functions.

- Reject spaces in HTTP Content-Length header values (CVE-2018-7159): The
  Node.js HTTP parser allowed for spaces inside Content-Length header
  values.  Such values now lead to rejected connections in the same way as
  non-numeric values.

While we are at it, also add a hash for the license file.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/nodejs/nodejs.hash
package/nodejs/nodejs.mk

index 4adef79dca9c03a3dddc8884c7f4628e9effe5a6..b3900f6a7dc070a3c6d4c85de2af98c7441413a0 100644 (file)
@@ -1,2 +1,5 @@
-# From http://nodejs.org/dist/v8.10.0/SHASUMS256.txt
-sha256 b72d4e71618d6bcbd039b487b51fa7543631a4ac3331d7caf69bdf55b5b2901a  node-v8.10.0.tar.xz
+# From http://nodejs.org/dist/v8.11.1/SHASUMS256.txt
+sha256 40a6eb51ea37fafcf0cfb58786b15b99152bec672cccf861c14d1cca0ad4758a  node-v8.11.1.tar.xz
+
+# Hash for license file
+sha256 b87be6c1479ed977481115869c2dd8b6d59e5ea55aa09939d6c898242121b2f5  LICENSE
index e1dd11cef504907bb6600f21a5cae364fecc8b8a..2642525c47733cc85527853af8481fca702a857f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-NODEJS_VERSION = 8.10.0
+NODEJS_VERSION = 8.11.1
 NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
 NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
 NODEJS_DEPENDENCIES = host-python host-nodejs c-ares \