Simplify AVR32 gcc build (libmudflap, doesn't work, so applied even though objections)
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 1 Aug 2007 08:58:14 +0000 (08:58 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Wed, 1 Aug 2007 08:58:14 +0000 (08:58 -0000)
toolchain/gcc/Config.in
toolchain/gcc/Config.in.2
toolchain/gcc/Makefile.in

index 727b78997a20b3dfc0046d604eb5de0b13f3e50c..b00df227a49c224a2698080629fac368d90e06fb 100644 (file)
@@ -140,16 +140,6 @@ config BR2_GCC_USE_SJLJ_EXCEPTIONS
          proper stack unwinding during exception handling.  Most people
          can leave this set to n.
 
-config BR2_GCC_AVR32_CONFIGURATION
-       bool "Enable default AVR32 GCC configuration"
-       default y
-       depends BR2_avr32
-       help
-         For the AVR32 platform there is some configuration which are not
-         supported.
-
-         Currently this will add "--disable-libmudflap" to configure.
-
 config BR2_EXTRA_GCC_CONFIG_OPTIONS
        string "Additional gcc options"
        default ""
index 0b209ec7afd0e0175caefded1a9a9af54daf7b6f..e556392c13ac58b7a8c62f9e3f3291377397c16b 100644 (file)
@@ -2,19 +2,9 @@ config BR2_PACKAGE_GCC_TARGET
        bool "native toolchain in the target filesystem"
        default n
        help
-         If you want the target system to be able to run 
+         If you want the target system to be able to run
          binutils/gcc and compile native code, say Y here.
 
-config BR2_GCC_TARGET_AVR32_CONFIGURATION
-       bool "Enable default AVR32 GCC configuration"
-       default y
-       depends BR2_avr32 && BR2_PACKAGE_GCC_TARGET
-       help
-         For the AVR32 platform there is some configuration which are not
-         supported.
-
-         Currently this will add "--disable-libmudflap" to configure.
-
 config BR2_EXTRA_TARGET_GCC_CONFIG_OPTIONS
        string "Additional target gcc options"
        default ""
index ec14b25bd1f10bbcd81497e9d5b7b96a796bf483..b087eb22c5cf039fb5baafb4b2931b2897afe3f7 100644 (file)
@@ -12,7 +12,7 @@ EXTRA_GCC_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_GCC_CONFIG_OPTIONS)))
 #"))
 
 # AVR32 GCC configuration
-ifeq ($(strip $(BR2_GCC_AVR32_CONFIGURATION)),y)
+ifeq ($(strip $(BR2_avr32)),y)
 EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
 endif
 
@@ -86,7 +86,7 @@ endif
 endif # BR2_PREFER_IMA=y
 
 # AVR32 target GCC configuration
-ifeq ($(strip $(BR2_GCC_TARGET_AVR32_CONFIGURATION)),y)
+ifeq ($(strip $(BR2_avr32)),y)
 EXTRA_TARGET_GCC_CONFIG_OPTIONS+=--disable-libmudflap
 endif