package/librtlsdr: drop cmake workaround
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Mon, 25 Jan 2021 21:48:17 +0000 (22:48 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 26 Jan 2021 16:35:09 +0000 (17:35 +0100)
Drop workaround for cmake < 3.10 (not needed since commit
d4773b610a40be1d3ac7d793033abaf4eb2491ed)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/librtlsdr/librtlsdr.mk

index 47586bdfb20d8a48ed5c0be2c7cace29fd2ee414..7796d1096a1c86b7a9e6f39546d07eed8492e729 100644 (file)
@@ -34,15 +34,4 @@ else
 LIBRTLSDR_CONF_OPTS += -DENABLE_ZEROCOPY=OFF
 endif
 
-# In case of static-lib-only builds, CMake's FindThreads.cmake code tries to
-# get the right flags, checking first for -lpthreads, then -lpthread, and lastly
-# for -pthread.
-# The 2 first link checks fail because of undefined symbols: __libc_setup_tls.
-# In the later check, CMake successfully compiles and links the test program,
-# but it also tries to run it, which is wrong when cross-compiling.
-#
-# The following CMake variable only disables the TRY_RUN call in the -pthread
-# test.
-LIBRTLSDR_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
-
 $(eval $(cmake-package))