ofono: fix missing systemd and dbus files
authorMike Williams <mike@mikebwilliams.com>
Thu, 15 Oct 2015 14:35:07 +0000 (10:35 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 17 Oct 2015 14:31:07 +0000 (16:31 +0200)
Ofono's service file was not being installed when systemd was selected
as the init system.

Without ofono.conf in /etc/dbus-1/system.d, ofonod cannot take its
dbus name on the system bus and will fail to start with a permission
denied error.

Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ofono/ofono.mk

index f1a63e2beca8083127a4032669ca28098bcef430..7899750461bf640812cacd4c0af6e54fbf8c8173 100644 (file)
@@ -16,7 +16,10 @@ OFONO_DEPENDENCIES = \
        libcap-ng \
        mobile-broadband-provider-info
 
-OFONO_CONF_OPTS = --disable-test
+OFONO_CONF_OPTS = \
+       --disable-test \
+       --with-dbusconfdir=/etc \
+       $(if $(BR2_INIT_SYSTEMD),--with-systemdunitdir=/usr/lib/systemd/system)
 
 # N.B. Qualcomm QMI modem support requires O_CLOEXEC; so
 # make sure that it is defined.