gcc: make branding unconditional
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 3 Mar 2015 16:44:04 +0000 (13:44 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 3 Mar 2015 20:58:43 +0000 (21:58 +0100)
We don't support older versions that can't handle it any more.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index 477f846b895ef0e9cd274080ac9f9a6ba5e4404b..ffac15c7869f0d74f812b3c7143deb3aa6cf101b 100644 (file)
@@ -91,7 +91,9 @@ HOST_GCC_COMMON_CONF_OPTS = \
        --disable-libssp \
        --disable-multilib \
        --with-gmp=$(HOST_DIR)/usr \
-       --with-mpfr=$(HOST_DIR)/usr
+       --with-mpfr=$(HOST_DIR)/usr \
+       --with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
+       --with-bugurl="http://bugs.buildroot.net/"
 
 # Don't build documentation. It takes up extra space / build time,
 # and sometimes needs specific makeinfo versions to work
@@ -206,13 +208,6 @@ ifneq ($(GCC_TARGET_MODE),)
 HOST_GCC_COMMON_CONF_OPTS += --with-mode=$(GCC_TARGET_MODE)
 endif
 
-# Branding works on >= 4.3
-ifneq ($(findstring x4.2.,x$(GCC_VERSION)),x4.2.)
-HOST_GCC_COMMON_CONF_OPTS += \
-       --with-pkgversion="Buildroot $(BR2_VERSION_FULL)" \
-       --with-bugurl="http://bugs.buildroot.net/"
-endif
-
 # Enable proper double/long double for SPE ABI
 ifeq ($(BR2_powerpc_SPE),y)
 HOST_GCC_COMMON_CONF_OPTS += \