cairo: add host variant
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 19 Apr 2015 09:48:19 +0000 (06:48 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Apr 2015 12:40:22 +0000 (14:40 +0200)
Required for host-pango, which in turn is required for host-librsvg and
at last midori.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cairo/cairo.mk

index 2c553382aab2bfcec2bd0400deb68d475044b824..098f24953df19467f939bc6e95a603c340cb9144 100644 (file)
@@ -74,6 +74,33 @@ CAIRO_CONF_OPTS = \
 
 CAIRO_DEPENDENCIES = host-pkgconf fontconfig pixman
 
+# Just the bare minimum to make other host-* packages happy
+HOST_CAIRO_CONF_OPTS = \
+       --enable-trace=no \
+       --enable-interpreter=no \
+       --disable-directfb \
+       --enable-ft \
+       --disable-gobject \
+       --disable-glesv2 \
+       --disable-vg \
+       --disable-xlib \
+       --disable-xcb \
+       --without-x \
+       --disable-xlib-xrender \
+       --disable-ps \
+       --disable-pdf \
+       --enable-png \
+       --disable-script \
+       --disable-svg \
+       --disable-tee \
+       --disable-xml
+HOST_CAIRO_DEPENDENCIES = \
+       host-freetype \
+       host-fontconfig \
+       host-libpng \
+       host-pixman \
+       host-pkgconf
+
 # DirectFB svg support rely on Cairo and Cairo DirectFB support depends on
 # DirectFB. Break circular dependency by disabling DirectFB support in Cairo
 # (which is experimental)
@@ -172,3 +199,4 @@ CAIRO_CONF_OPTS += --disable-xml
 endif
 
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))