package/vlc: add optional dependency to libarchive
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:28 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 11:36:29 +0000 (13:36 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index 7ce1f57cd896ec512f7bd695e43a1628fa5e6a43..d34ab2a9e088775beac3374672e148225b0e0ca6 100644 (file)
@@ -41,7 +41,6 @@ VLC_CONF_OPTS += \
        --disable-a52 \
        --disable-addonmanagermodules \
        --disable-aom \
-       --disable-archive \
        --disable-aribb25 \
        --disable-aribsub \
        --disable-asdcp \
@@ -222,6 +221,13 @@ else
 VLC_CONF_OPTS += --disable-opus
 endif
 
+ifeq ($(BR2_PACKAGE_LIBARCHIVE),y)
+VLC_CONF_OPTS += --enable-archive
+VLC_DEPENDENCIES += libarchive
+else
+VLC_CONF_OPTS += --disable-archive
+endif
+
 ifeq ($(BR2_PACKAGE_LIBASS),y)
 VLC_CONF_OPTS += --enable-libass
 VLC_DEPENDENCIES += libass