u-boot: halt build early with description if no u-boot board name is set
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 14:49:19 +0000 (14:49 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jan 2009 14:49:19 +0000 (14:49 -0000)
target/u-boot/Makefile.in

index 2c48c3898e718c43fb9a98e751249c316ce89c1a..e4b54a62c3412a64c00e66c8bc07f71d1ca0d090 100644 (file)
@@ -281,6 +281,12 @@ $(U_BOOT_AUTOSCRIPT).$(PROJECT): $(U_BOOT_AUTOSCRIPT) $(MKIMAGE)
 #############################################################
 ifeq ($(BR2_TARGET_UBOOT),y)
 TARGETS+=u-boot
+
+# we NEED a board name
+ifeq ($(UBOOT_BOARD_NAME),)
+$(error NO U-Boot board name set. Check your BR2_TARGET_UBOOT_BOARDNAME setting)
+endif
+
 endif
 
 u-boot-status: