pciutils: bump to version 3.1.8 and other fixes
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 15 Oct 2011 03:07:26 +0000 (00:07 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Oct 2011 21:07:27 +0000 (23:07 +0200)
Bump to pciutils version 3.1.8
Also make it build after busybox because it's got a lightweight
lspci whereas the full-blown is preferred.
Ditch the pci.ids skeleton comment since it's been shipped for some time
now.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pciutils/Config.in
package/pciutils/pciutils.mk

index 7b318dae7fb794da223717f07c9c51a07aa020ba..a082f239977dc43f71b6e77a08dd1380f0e13330 100644 (file)
@@ -4,7 +4,4 @@ config BR2_PACKAGE_PCIUTILS
          Various utilities dealing with the PCI bus.
          Provides things like setpci and lspci.
 
-         You'll need a copy of pci.ids or pci.ids.gz in your
-         target skeleton to enjoy verbose output.
-
          http://atrey.karlin.mff.cuni.cz/~mj/pciutils.html
index 52f5f67ff4b7493b178519fb8783724c4f71148c..28f80d462609d055c1253f3849bebf65d27ebeec 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-PCIUTILS_VERSION = 3.1.7
+PCIUTILS_VERSION = 3.1.8
 PCIUTILS_SITE = ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci
 ifeq ($(BR2_PACKAGE_ZLIB),y)
        PCIUTILS_ZLIB=yes
@@ -15,6 +15,11 @@ endif
 PCIUTILS_DNS=no
 PCIUTILS_SHARED=yes
 
+# Build after busybox since it's got a lightweight lspci
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+       PCIUTILS_DEPENDENCIES += busybox
+endif
+
 define PCIUTILS_CONFIGURE_CMDS
        $(SED) 's/wget --no-timestamping/wget/' $(PCIUTILS_DIR)/update-pciids.sh
        $(SED) 's/uname -s/echo Linux/' \